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Hey, 

My name is Puneet . I’m a 26 years old 

guy from India.

AWESOME
Thank you for downloading this guide

I’m on a mission.

And, my mission is to help people & learn

Microsoft Excel.

So, that’s why I am helping people who 

want to learn Microsoft Excel.

I have founded ExcelChamps to reach 

more & more people like you.

I have created this E-Book with love, for 

people who want to drive their skills to 

next level.

© ExcelChamps.com

With love and respect,

Puneet Gogia

Follow the real me on Instagram

https://www.instagram.com/iampuneetgogia/


This copy is purely dedicated to you. 

You can use it in several ways. Save it 

in your laptop, mobile, take a printout, 

and please, no need to say thanks.

Important Message

But you can’t sell it or you can’t make 

a change in it because all rights of this 

copy is with ExcelChamps.com. 

If want some changes in it or some 

addition to it, you can mail me.

And, if you like this guide,  don’t 

forget to share it with your buddies. 

I’m sure they will appreciate it.

Here’s you can share it.
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Watch Window in 
Excel

Use watch window to track important 

cells in your workbook.

You can add all those important cells 

in watch window to track them on real 

time. 

How To

1. Go to Formula Tab -> Watch Window -> Add 

Watch.

2. Select the cell you want to add to watch 

window.

Once you add a cell into watch window it will show 

you 6 different components of a cell.
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Format Painter in 
Excel

Use format painter to copy formatting 

from one section to another.

When you click on it, it will simply 

copy a cell formatting & you can apply 

it on another cell.

How To

1. Select the cell or a range to copy format.

2. Go to Home -> Clipboard -> Format Painter.

3. Once you click on the format painter, your 

mouse pointer will change icon.

4. Now, you can select the cell or range on which 

you want to paste that format.
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Fill Justify 
in Excel

The single core motive to use fill justify 

in excel is to merge the data from 

multiple cells into a single cell.

If you have any other idea to merge 

text into one cell, leave it

How To

1. First of all, make sure that the column in which 

your text is captured is wide enough to store 

the entire text into a single cell.

2. Now, select all the cell in which text is stored.

3. Go to Home Tab -> Editing Group -> Fill -> 

Justify.
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Sort Columns 
in Excel

Sorting columns in excel mean sorting 

data from left to right [horizontal 

direction].

This is useful when you have to 

streamline your data columns.

How To

1. Select the data you want to sort.

2. Go to Data Tab → Sort & Filter → Click on Sort 

Button. 

3. Options button → Sort left to right & click OK.

4. Now select the row on the basis of which you 

want to sort your data & click OK.
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Undo Redo Buttons 
in Excel

You can use undo and redo buttons 

from quick access toolbar which has a 

list of activities you have done.

You can undo or redo to a particular 

activity by using these buttons.

How To

1. Go to File Tab → Options → Quick Access 

Toolbar → Select UNDO & REDO command 

from “Choose commands from”.

2. Add both the commands to your quick access 

toolbar.

3. Click Ok.
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Flash Fill 
in Excel

It is like a copy cat, which can do the 

things in the same pattern in which 

you are doing.

You just have to do that operation 

once & Flash Fill do it for the rest.

How To

1. Go to Home Tab -> Editing -> Fill -> Flash Fill.

2. You can also add flash fill option to the quick 

access toolbar for your convenience.

3. To activate automatic flash fill option. Go to File 

-> Options -> Advance -> Editing Options -> 

tick mark automatically flash fills.

© ExcelChamps.com



Image in Cell 
Comment

This is a very useful feature of the cell

comment. You can add images to

describe the content of the cell.

How To

1. Open format comment option, go to color & 

lines options.

2. Click on the color drop down menu & then click 

on fill effects.

3. Select picture tab and click on select picture to 

add the picture.
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Add Secondary Axis 
in Chart

You can add a secondary axis to your

chart to show more than one data

values.

That means, two independent data 

lines or bars.

How To

1. Select the data series for which you want to add 

a secondary axis.

2. Right Click on it & Go to Format Data Series →

Series Option → Activate Secondary Axis.

3. Now, you have a two scales in your chart.
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Camera Tool 
in Excel

Like a normal camera, this camera

captures the picture of cell range.

It can help you to copy a range & 

create a live picture of it and you can 

paste it anywhere in your worksheet.

How To

1. From your quick access toolbar, click on the 

down arrow.

2. Then, click on more commands.

3. Now, In excel options select all commands 

from “Choose Commands From”.

4. Select Camera from the list -> add -> Click OK.
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In-Built Data Entry 
Form

Microsoft Excel is loaded with a built 

in data entry form. You can use it to 

enter your data into worksheet. But 

before that you need to activate this 

form.

How To

• Method1: Select your data & press Alt + D + O.

• Method2: Add it in your quick access toolbar.

• Method3: Run the below macro to activate it.
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Sub DataForm()

ActiveSheet.ShowDataForm

End Sub



Print Titles on 
Every Page

You can use “Print Title” option to 

print some specific data at the top of 

each page you print.

You can select a range of cells for this 

to print.

How To

1. Go to -> Page Layout -> Sheet. Add Print Area 

in print area input box which you want print.

2. In Rows To Repeat At Top add the row area 

which you want to print at top of every page.

3. In Columns To Repeat At Left, add the column 

area which you want to print at left of every 

page. Then click OK.
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Create a Cell 
Message

You can create a cell message for 

some specific cells. 

Whenever user select those cell, it will 

pop-up a message which you have 

specified.

How To

1. Go to Data tab -> Data Tools.

2. In Data Validation

3. Click input message

4. Enter Title & Message

5. Click OK
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Multiply With 
Paste Special

For example, you have a data table 

with call tariff rates from India to other 

countries. Due to some hike in costing 

you have to increase your tariff rates 

by 20%. You can use here paste 

special operations to multiply.

How To

1. Select the cell in which you have your %age of 

increment & copy it.

2. Now, select the entire range on which you want 

to apply the calculation.

3. Use shortcut key Alt + E + S.

4. Go to Operation, select the “multiply” option, 

click okay.
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Change Display 
Units

If you are dealing with the large 

number in your excel chart, you can 

change the units for your axis values.

It will help user to understand the 

values easily.

How To

1. Select chart axis your chart and open format 

“Format Axis” options (With right click).

2. In axis options, go to “Display Units” where you 

can select unit for your axis values.

3. Change it wo million or thousands.
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Hide Empty Gap 
in Chart

Let’s say if you have a chart with 

monthly sales in which Jun has no 

amount & cell is empty. You can: show 

gap for the empty cell, use a zero or 

connect data points with the line. 

How To

1. Right, click on your chart & select “Select Data”.

2. In select data window, click on “Hidden and 

Empty Cell”.

3. Select your desired option from “Show Empty 

Cell as”.
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Insert Picture in 
Chart

It has a limited use but it’s pretty cool 

to use an image in your chart.

It will help you to make your charts 

more meaningful and understandable 

to your user.

How To

1. Select data bar in your chart.

2. Go to Fill & Line. In “Fill” option, select picture 

& texture fill.

3. In “Insert Picture From” click on file to select an 

image.

4. Select “Stack” after that.
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Copy Chart 
Formatting

Let’s say, with your extreme efforts, 

you have formatted a chart. And, you 

realize that you have more charts to 

format. It’s a pain. But, I have a super 

quick solution.

How To

1. Right-click on the chart from which you want to 

copy the chart formatting. Click on the copy.

2. Right-click on the other chart. Go to Home tab -

> Clipboard -> Paste -> Paste Special.

3. Now, you have a pop-up window. Select 

formats. 

4. Click OK
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Auto Format 
Option

AutoFormat is a very handy & 

powerful tool to apply some quick 

formats to your data.

You just have to select a format to 

apply & Excel will apply a pre-

designed format to your data.

How To

1. Go to File → Options → Quick Access Toolbar 

→ Select AutoFormat from the list.

2. Add to the Quick access toolbar.

3. Select your data.

4. Click on the auto format button in quick access 

toolbar.

5. Select the format you want. Click OK.
© ExcelChamps.com



Smooth Lines In 
Line Chart

If you love to use line chart then you 

are awesome but it would be more 

awesome if you use a smooth line in 

the chart. This will give a smart look to 

your chart.

How To

1. Select data line in your chart & right click on it.

2. Select “Format Data Series”.

3. Go To Fill & Line -> Line -> Tick “Smoothed 

Line”.
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Show Data for 
Hidden Cells

When you hide a cell from the data 

range of your chart, it will also hide 

from the chart as well.

And, if you want not to hide data 

values from your chart even a cell is 

hidden, just follow these steps.

How To

1. Select your chart & right click on it.

2. Go to -> Select Data -> Hidden and empty 

cells.

3. From the pop-up window, tick mark “Show data 

in hidden rows & columns”.
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Highlight 
Duplicates

Easiest way to highlight duplicate 

values in entire worksheet or in 

selected range of cells is by using 

Conditional Formatting.

You just need to use following simple 

steps. 

How To

1. Select the data -> Go to Home Tab.

2. In Styles -> Click Conditional Formatting.

3. In Highlight Cell Rules -> Select Highlight 

Duplicate Values.
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Change Local 
File Location

Want to open same location every 

time when you save your file?

This way when you open save as 

dialog box you will always get the 

same location.

How To

1. Go to File -> Options-> Save -> Default Local 

File Location.

2. Enter new path you want to set as default.

3. Click OK.
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Highlight Top / 
Bottom 10

You can use conditional formatting to 

highlight top 10 or bottom 10 values.

There is already a pre-defined color 

for bottom values (red) and top values 

(green). But you can change it, if you 

need.

How To

1. Select your data.

2. Go to Home -> Style -> Conditional Formatting 

-> Top/Bottom Rules.

3. Select the option you want to apply.
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Freeze Pane 
(rows & columns)
Working with large data sets?

Then it’s must to freeze headings.

By freezing panes you set a row and 

column as a fixed header and fixed 

column respectively.

How To

1. Go to View Tab -> Windows -> Freeze Panel.

2. You have three option to freeze.

A. One is to free first column of the 

worksheet.

B. Second is to freeze first row.

C. Third is to freeze rows & columns bases on 

the current selection. © ExcelChamps.com



Quickly Add a 
Hyperlink 

Using a hyperlink you can link a cell 

with a specific webpage, file or a place 

in your workbook.

And, in just one click you get to that 

particular place.

How To

1. Select the cell, right click & select Add 

Hyperlink. 

2. Now, you have a pop-up window.

3. Add the address of the location into address 

bar. You can also add a ScreenTip to show a 

message on mouse hover.

4. Click OK.
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Group Dates In 
Pivot Table

Grouping dates in pivot table will 

allow you to combine dates in the 

form of months, quarters, years.

And, the best part of this option is you 

don’t have to put those extra columns 

in your source data.

26

How To

1. Select any of the cells which has a date in it.

2. Right click on it & select group.

3. You will get a pop-up window to group dates.

4. Select “Month” in the group by option.

5. Click OK.
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Delete Blank 
Cells

If you have blank cells in your data & 

you want to delete them you can do 

this by using go to special option.

It will select all the blank cells and then 

you delete them.

How To

1. Press CTRL+G to open the Go To Dialog Box.

2. Go to > Special > Blanks.

3. Select cells, rows or columns.

4. Click OK.
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Goal Seek –
Problem Solver

By using goal seek you can find a 

possible input or value to get the 

desired result.

Means, if you know what is the actual 

result, you can use it to find the best 

input value to get that result.

How To

1. Go to Data Tab → What If Analysis → Goal 

Seek.

2. Set Cell – Cell in which you want the desired 

result.

3. To Value – Value you want as a result.

4. By Changing Cell – Cell in which you want 

alteration to come up with the result.
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Use Text To 
Speech

Text-To-Speech in Excel is an option 

which allows you to make excel speak 

what you have typed in your 

spreadsheet.

It will simply use window TTS voice to 

speak the data you have.

How To

1. Go to customize ribbon options and select 

"Main Tab" from the drop-down option.

2. Now, select the home tab, add a new group.

3. Choose 'Commands Not In Ribbon" from 

"Chose Commands From" option and select all 

5 commands starting with word "Speak". Add 

them and click OK,
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Use Text To 
Speech

Microsoft has introduced a nice app 

feature in excel 2013. Fortunately, we 

also have a Speed-O-Meter on app 

store & it’s free.

So, before using it, you have to 

download it.

How To

1. Go to Insert -> Store -> Search for Gauge Chart 

& Install it.

2. It will give you a cool gauge chart which looks 

like a speed-o-meter.
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Bonus Stuff

1. Expense Tracking Template

2. Daily Sales Template

3. Gantt Chart Template

4. Inventory Management Template

5. Barcode Generator Template

6. 101 Excel Functions with Examples
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http://excelchamps.com/blog/one-page-excel-expense-tracking-template/
http://excelchamps.com/blog/daily-sales-report-template/
http://excelchamps.com/blog/one-page-excel-expense-tracking-template/
http://excelchamps.com/blog/excel-inventory-management-template-user-forms-vba/
http://excelchamps.com/blog/barcode-generator-template-in-excel/
http://excelchamps.com/blog/excel-functions/
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